Analytics Unavailable
Incident Report for Avetta CFG
Resolved
The Analytics website is back online
Posted Jan 03, 2025 - 15:33 PST
Investigating
The Analytics website may be unavailable. We apologize for any inconvenience. Our operations teams are aware and actively working to resolve the issue.
Posted Jan 03, 2025 - 15:29 PST
This incident affected: CFG Analytics.