Analytics Unavailable

Incident Report for Avetta CFG

Resolved

The Analytics website is back online
Posted Nov 23, 2025 - 23:38 PST

Investigating

The Analytics website may be unavailable. We apologize for any inconvenience. Our operations teams are aware and actively working to resolve the issue.
Posted Nov 23, 2025 - 18:11 PST
This incident affected: CFG Analytics.